Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

PyRAF cannot be executed

haojingyanhaojingyan Member Posts: 2
I'm having serious problems with SSBREL and Ureka - neither seems to work at my Fedora 20 Linux. I first installed SSBREL (a fresh install, using the installation script at, and it seemed to go all well. But then when I executed "pyraf", it crashed. I'm attaching the error message below. I then tried to install Ureka seperately (using the installation script at, and the same error happened.

Please help!

*** The error message ***

Traceback (most recent call last):
File "/home/yhj/astro_softwares/ssbrel/python/bin/pyraf", line 4, in
__import__('pkg_resources').run_script('pyraf==2.1.6', 'pyraf')
File "/home/yhj/astro_softwares/ssbrel/python/lib/python2.7/site-packages/", line 517, in run_script
self.require(requires)[0].run_script(script_name, ns)
File "/home/yhj/astro_softwares/ssbrel/python/lib/python2.7/site-packages/", line 1436, in run_script
exec(code, namespace, namespace)
File "/home/yhj/astro_softwares/ssbrel/python/lib/python2.7/site-packages/pyraf-2.1.6-py2.7-linux-x86_64.egg/EGG-INFO/scripts/pyraf", line 94, in
from pyraf import doCmdline, _use_ipython_shell, runCmd, __version__
File "/home/yhj/astro_softwares/ssbrel/python/lib/python2.7/site-packages/pyraf-2.1.6-py2.7-linux-x86_64.egg/pyraf/", line 223, in
File "/home/yhj/astro_softwares/ssbrel/python/lib/python2.7/site-packages/pyraf-2.1.6-py2.7-linux-x86_64.egg/pyraf/", line 261, in Init, _hush=hush, _save=1)
File "/home/yhj/astro_softwares/ssbrel/python/lib/python2.7/site-packages/pyraf-2.1.6-py2.7-linux-x86_64.egg/pyraf/", line 359, in run
self._run(redirKW, specialKW)
File "/home/yhj/astro_softwares/ssbrel/python/lib/python2.7/site-packages/pyraf-2.1.6-py2.7-linux-x86_64.egg/pyraf/", line 1667, in _run
File "/home/yhj/astro_softwares/ssbrel/python/lib/python2.7/site-packages/pyraf-2.1.6-py2.7-linux-x86_64.egg/pyraf/", line 1470, in _runCode
self._clFunction(*parList, **kw)
File "", line 88, in login
File "/home/yhj/astro_softwares/ssbrel/python/lib/python2.7/site-packages/pyraf-2.1.6-py2.7-linux-x86_64.egg/pyraf/", line 168, in __getattr__
raise AttributeError("Undefined IRAF task `%s'" % (attr,))
AttributeError: Undefined IRAF task `chkupdate’


  • dborncampdborncamp Member, Institute_Staff Posts: 7
    haojingyan, Are you just trying to start Pyraf or are you trying to use one of the modules in DrizzlePac?
  •[email protected] Member, Institute_Staff, Moderator_DrizzlePac Posts: 32
    Hello, I checked with the software developer and she says :

    I've seen this error once recently, and the solution was to edit so that this block is removed:

    # Check for updates to the system

    # Notify the user if we're using the global login.
    path (".") | scan (s1)
    if ( osfn("home$") != substr (s1, strldx("!",s1)+1, strlen(s1)) ) {
    printf (" *** Using global login file:\n", osfn("home$"))

    If that doesn't work, please submit your question to our Help Desk at [email protected] for more personalized assistance with your particular setup.
  • haojingyanhaojingyan Member Posts: 2
    Thanks folks! By removing "chkupdate" from my the problem was indeed gone. Well, I didn't expect that "ur_setup" was smart enough to look for a from my IRAF directory; I was executing PyRAF from a directory that has no at all and yet still go this problem. Anyway, thanks for the help!
Sign In or Register to comment.